Vikakotik5
24.08.2022 20:08

Написать программу, которая ищет сумму наибольшего + наименьшего элемента массива из 20 элементов случайных чисел (сам массив надо обязательно вывести на экран после заполнения)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
risimonenko
04.01.2022 07:02
1)program fagasg;
var x1,y1,r: real;
begin
Writeln('Введите х1');
readln(x1);
Writeln('Введите у1');
readln(y1);
r:=sqrt(x1*x1+y1*y1);
Writeln('Расстояние от х1 до у1=',r);
end.
2)Program fsgasghfd;
var c,s: real;   
a,b: integer;
begin
Writeln('Введите первое целое число');
readln(a);
Writeln('Введите второе целое число');
readln(b);
Writeln('Введите дробное число');
readln(c);
If ((a>0) and (b>0) and (c>0)) or ((a<0) and (b<0) and (c<0)) then 
s:=a+b+c
else writeln('Знаки разные');
If ((a>0) and (b>0) and (c>0)) or ((a<0) and (b<0) and (c<0)) then Writeln('Сумма чисел:',s);
end.
3)Program wrqrwqr;
var A: Array[1..100] of integer;   
B: Array[1..100] of integer;   
C: Array[1..100] of integer;   
s,i,h,g: integer;
begin
h:=0;
g:=0;
Writeln('введите размерность массива');
readln(s);
Writeln('Вводится первый массив');
For i:=1 to s do 
begin   
Writeln('Введите элемент массива №',i);   
readln(A[i]); 
end;
Writeln('Вводится второй массив');
For i:=1 to s do 
begin   
Writeln('Введите элемент массива №',i);   
readln(B[i]); 
end;
For i:=1 to s do  begin   
If A[i]>B[i] then C[i]:=A[i]     
else C[i]:=B[i];   
If C[i] mod 2=1 then h:=h+1;   
If C[i] mod 2=0 then g:=g+1; 
end; 
Writeln('Количество нечётных элементов в массиве:',h); 
Writeln('Количество чётных элементов в массиве:',g);
end.
0,0(0 оценок)
Ответ:
Jina9845
04.01.2022 07:02
1)program fagasg;
var x1,y1,r: real;
begin
Writeln('Введите х1');
readln(x1);
Writeln('Введите у1');
readln(y1);
r:=sqrt(x1*x1+y1*y1);
Writeln('Расстояние от х1 до у1=',r);
end.
2)Program fsgasghfd;
var c,s: real;   
a,b: integer;
begin
Writeln('Введите первое целое число');
readln(a);
Writeln('Введите второе целое число');
readln(b);
Writeln('Введите дробное число');
readln(c);
If ((a>0) and (b>0) and (c>0)) or ((a<0) and (b<0) and (c<0)) then 
s:=a+b+c
else writeln('Знаки разные');
If ((a>0) and (b>0) and (c>0)) or ((a<0) and (b<0) and (c<0)) then Writeln('Сумма чисел:',s);
end.
3)Program wrqrwqr;
var A: Array[1..100] of integer;   
B: Array[1..100] of integer;   
C: Array[1..100] of integer;   
s,i,h,g: integer;
begin
h:=0;
g:=0;
Writeln('введите размерность массива');
readln(s);
Writeln('Вводится первый массив');
For i:=1 to s do 
begin   
Writeln('Введите элемент массива №',i);   
readln(A[i]); 
end;
Writeln('Вводится второй массив');
For i:=1 to s do 
begin   
Writeln('Введите элемент массива №',i);   
readln(B[i]); 
end;
For i:=1 to s do  begin   
If A[i]>B[i] then C[i]:=A[i]     
else C[i]:=B[i];   
If C[i] mod 2=1 then h:=h+1;   
If C[i] mod 2=0 then g:=g+1; 
end; 
Writeln('Количество нечётных элементов в массиве:',h); 
Writeln('Количество чётных элементов в массиве:',g);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота