копытирина
11.06.2021 07:57

Написать программу на Pascal Требования к программе:
• Программа должна решать три задачи: (табуляция функции, обработка одномерного массива,
обработка матрицы). Варианты задач могут быть
выбраны в произвольном порядке.
• Все задачи должны быть оформлены в виде подпрограмм
• Головная программа должна быть оформлена в виде меню с
пунктами выбора соответствующей задачи, посредством ввода
пользователем номера задачи
• Обязательно использовать как процедуры, так и функции (как
минимум один раз)
• Для передачи данных в подпрограмму и возврата результатов
глобальные переменные не использовать
• Программы обработки массивов должны содержать как минимум
три подпрограммы: ввода, вывода и непосредственной обработки
Дополнительно: добавить в меню пункт “Завершение программы” по
вводу пользователем определенного символа. Не завершать программу пока
пользователь не выберет этот пункт меню.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
bondarantona
01.02.2022 23:14

var i,n,m,sum,pr,k,j:longint;

begin

 sum:=0; pr:=1;

 write('m: '); readln(m);

 write('n: '); readln(n);

 i:=2;

 repeat

   if m mod i = 0 then

     begin

       sum:=sum+i;

       m:=m div i;

       i:=2;

     end

       else inc(i);

 until m=1;

 writeln('Sum_M:', sum);

 for i:=2 to n div 2 do

   if n mod i = 0 then

     begin

       k:=2;

       for j:=2 to i div 2 do

         if i mod j = 0 then inc(k);

       if (k>2)and(i mod 3 = 0 ) then

         pr:=pr*i;

     end;  

 writeln('Proizv_N:', pr);

 if sum>pr then writeln('Da, sum prost del M > proizv sost del N')

   else

     writeln('Net, sum prost del M < proizv sost del N');

end.

0,0(0 оценок)
Ответ:
creeperm477
01.02.2022 23:14

var i,n,m,sum,pr,k,j:longint;

begin

 sum:=0; pr:=1;

 write('m: '); readln(m);

 write('n: '); readln(n);

 i:=2;

 repeat

   if m mod i = 0 then

     begin

       sum:=sum+i;

       m:=m div i;

       i:=2;

     end

       else inc(i);

 until m=1;

 writeln('Sum_M:', sum);

 for i:=2 to n div 2 do

   if n mod i = 0 then

     begin

       k:=2;

       for j:=2 to i div 2 do

         if i mod j = 0 then inc(k);

       if (k>2)and(i mod 3 = 0 ) then

         pr:=pr*i;

     end;  

 writeln('Proizv_N:', pr);

 if sum>pr then writeln('Da, sum prost del M > proizv sost del N')

   else

     writeln('Net, sum prost del M < proizv sost del N');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота