gudroonnp010ou
24.08.2020 14:52

В паскале Составить программу для решения задачи: определить, является ли вводимое с клавиатуры число простым. (Простым называется число, имеющее только два делителя: 1 и само число).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Rezars19
10.08.2021 22:39
Program pr;
uses crt;

Var mas:array[1..1000, 1..1000] of integer;
N,M,i,j,k:integer;

Begin
Writeln('Введите размер матрицы N*M');
Write('N = ');
readln(N);
Write('M = ');
readln(M);

if (M>1000) or (N>1000) or (M<1) or (N<1)
then  
Writeln('Ошибка, указанные значения выходят за пределы матрицы')   else   
        Begin      
 Writeln('Введите элементы матрицы');      

k:=0; 
 for i:=1 to N do     
  for j:=1 to M do     
    Begin     
      readln(mas[i,j]);       
      if (mas[i,j] mod 2 = 0) then k:=k+1;     
    end; 
  
    Writeln();   
    Writeln('Исходная матрица');
   
   for i:=1 to N do   
     Begin     
       for j:=1 to M do     
          Begin     
             Write(mas[i,j], ' ')     
           end;     
      Writeln();   
     end;         

Writeln();   
Writeln('Количество четных элементов = ',k);      
 end;

readln;
end.
0,0(0 оценок)
Ответ:
FrostMorne
08.08.2022 10:54

type

firma = record

 fam:string;

 adres:string;

 end;

var

mas:array[1..8] of firma;

i,k:integer;

str:string;

begin

 mas[1].fam:='Кузин';

 mas[2].fam:='Куравлев';

 mas[3].fam:='Кудин';

 mas[4].fam:='Кульков';

 mas[5].fam:='Кубиков';

 mas[6].fam:='Иванов';

 mas[7].fam:='Петров';

 mas[8].fam:='Сидоров';

 mas[1].adres:='ул.Мира,7';

 mas[2].adres:='ул.Маркса,6';

 mas[3].adres:='ул.Комсомольская,17';

 mas[4].adres:='ул.Ленина,5';

 mas[5].adres:='ул.Центральная,18';

 mas[6].adres:='ул.Клубная,26';

 mas[7].adres:='ул.Чехова,2';

 mas[8].adres:='ул.Амосова,68';

 write('Введите фамилию сотрудника ->  ');readln(str);

 k:=0;

 for i:=1 to 8 do

 begin

   if str=mas[i].fam then

   begin

     k:=k+1;

     writeln('фамилия - ',mas[i].fam);

     writeln('адрес   - ',mas[i].adres);

   end;

 end;

 if k=0 then writeln('такого сотрудника нет!');

 readln;

end.

Объяснение:

Это ответ на задание 2

Qiwi +79172489972

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота