rpppppppyuv
15.06.2021 14:47

1составьте программу ,вычисляющую сумму кубов первых n натуральных чисел 2туристы в 1-ый день км.в каждый следующий день они проходили на 1.5 км > .составь программу ,вычисляющую сколько километров они пройдут за n дней. ,

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Vampire1234
25.06.2020 09:48
1
const
n = 100;
var
a: array[1..n] of word;
i, m: byte;
sum: word;
begin
write('Kol-vo chisel: ');
readln(m);
sum:=0;
for i:=1 to m do   
begin   
a[i] := i;   
write(a[i]:4);   
sum:=sum + sqr(a[i])*a[i];   
end;   
writeln;   
writeln('Sum = ', sum:4);  
readln;
end.

2
const
n = 100;
var
a: array[1..n] of word;
i, dn: byte;
km: real;
begin
write('Kol-vo dney: ');
readln(dn);
km:=7;
for i:=2 to dn do   
km:=km+(km+1.5);
writeln;
writeln('Turisty proshli ', km:4:1, ' km');
readln;
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота