Алуопо
19.10.2022 21:34

Написать программу вычисления суммы n членов ряда Код должен быть на Java. Если не знаете этот язык, то хотя бы объясните, как это делать, на том, которым вы владеете. Очень нужно.


Написать программу вычисления суммы n членов ряда Код должен быть на Java. Если не знаете этот язык,

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
МАШЕНЬКА881
06.03.2023 20:18
Const
  n = 11;

var
  x: array[1..n] of integer;
  i, k, d, s: integer;

begin
  Randomize;
  Writeln('Элементы массива');
  k := 0; s := 0;
  for i := 1 to n do
  begin
    d := Random(11) - 5;
    Write(d:3);
    if (i mod 2) = 0 then begin { четное место }
      if d = 1 then Inc(k);
      x[i] := d
    end
    else begin
      if d < 0 then s := s + d;
      x[i] := sqr(d)
    end
  end;
  Writeln;
  Writeln('Результирующий массив');
  for i := 1 to n do Write(x[i]:3);
  Writeln;
  Writeln('Количество единиц на четных местах равно ', k);
  Writeln('Сумма отрицательных элементов на нечетных местах равна ', s)
end.

Тестовое решение:
Элементы массива
 -3  0 -5  1  5  1 -3 -4  5 -3 -2
Результирующий массив
  9  0 25  1 25  1  9 -4 25 -3  4
Количество единиц на четных местах равно 2
Сумма отрицательных элементов на нечетных местах равна -13
0,0(0 оценок)
Ответ:
Vladislav525245264
02.12.2021 01:06

Итак, вот ответы:

1) 3. небольших общественных веб-сайтов.

2) 4. текстовом процессоре Word.

3) 3. веб-дизайн.

4) 4. html.

5) 1. структуру и содержание.

6) 2. не пишите слишком длинных текстов. текст разбивайте на небольшие абзацы, отделяя их друг от друга пустыми строками.

4. названия пунктов меню делайте краткими; недопустимо     растягивание названия пункта на несколько строк.

7) 4. шаблон.

все ответы на 100% верны, можете не волноваться. сама только, что тест и решила поделиться с вами правильными ответами. была рада удачи на экзаменах.)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота