shmiganastya06
05.04.2020 03:05

Написать программу на языке паскаль, в которой определяется какому времени года принадлежит введённый с клавиатуры порядковый номер месяца.за основу взято международное соглашение январь-1; декабрь-12.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
bashkirovarima
01.10.2020 13:06
Var a:integer;
Begin
  Write('Введите номер месяца: '); readln(a);
case a of
1:writeln('Январь - Зима');
2:writeln('Февраль- Зима');
3:writeln('Март- Весна');
4:writeln('Апрель- Весна');
5:writeln('Май- Весна');
6:writeln('Июнь-Лето');
7:writeln('Июль- Лето');
8:writeln('Август- Лето');
9:writeln('Сентябрь-Осень');
10:writeln('Октябрь -Осень');
11:writeln('Ноябрь- Осень');
12:writeln('Декабрь - Зима');
else writeln('Введено не верное число. Введите число от 1 до 12');
end;
end.

Либо упрощённый вариант:
Var a:integer;
Begin
Write('Введите номер месяца: '); readln(a);
case a of
1..2:writeln('Зима');
3..5:writeln('Весна');
6..8:writeln('Лето');
9..11:writeln('Осень');
12:writeln('Зима');
else writeln('Введено не верное число. Введите число от 1 до 12');
end;
end.
0,0(0 оценок)
Ответ:
polibfbxbdbdbcb
01.10.2020 13:06
Int mesyac;
Console.WriteLine("Введите месяц:");
mesyac = Convert.ToInt32(Console.ReadLine());
if (mesyac == 12 || mesyac == 1 || mesyac == 2)
{
Console.WriteLine("Зима");
}
if (mesyac > 2 && mesyac =< 5)
{
Console.WriteLine("Весна");
}
if (mesyac > 5 && mesyac =< 8)
{
Console.WriteLine("Лето");
}
if (mesyac > 8 && mesyac =< 11)
{
Console.WriteLine("Осень");
}
Console.ReadKey());
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота