keep19995
23.03.2021 06:49

Составьте программу которая позволяет закодировать строку путем замены всех звонких согласных на соответствующие глухие, а глухих на звонкие

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
алишер126
25.06.2020 07:29
const
  s: array [1..6] of char= ('б','в','г','д','ж','з');
  d: array [1..6] of char= ('п','ф','к','т','ш','с');

var
  c: string;
  i,j: integer;

begin
  readln(c);
  for i:= 1 to length(c) do
    for j:= 1 to 6 do
      if d[j]=c[i] then c[i]:= s[j]
      else
        if s[j]=c[i] then c[i]:= d[j];
  writeln(c)
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота