spongebob2353
24.10.2021 03:33

РЕШИТЬ ЧЕРЕЗ ПАСКАЛЬ и использовать цикл Компьютер 300 раз генерирует букву русского алфавита. Как только из этих букв можно составить слово '" Рубцовск", остановить генарацию и вывести общее количество сгенерированных букв.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
PinkPony11
20.01.2022 11:17
Ну почему,когда просят написать программу никто никогда не указывает язык программирования.я напишу на языке паскаль с входным и выходным файлом,но если это не тот язык,твоя проблема.(сообщения в фигурных скобках,это комментарии,просто для пояснение,можешь удалить их)

program p1;
const n=10;
var a : array[1..n] of integer;
i,b,c:integer;
begin 
randomize; 
assign(input,'input.txt');
reset(input);
assign(output,'output.txt');
rewrite(output);

for i:=1 to n do {Заполнение исходного массива}   
a[i]:=random(21)-10;
  
for i:=1 to n do {Вывод исходного массива(можно удалить эти строчки)}
write(a[i]:4);

c:=0; {Инверсия массива} 
for i:=1 to 2 do  begin   
b:=a[i];   
a[i]:=a[5-c];   
a[5-c]:=b;   
c:=c+1; 
end; 
c:=0; 
for i:=6 to 8 do 
begin   
b:=a[i];   
a[i]:=a[10-c];   
a[10-c]:=b;   
c:=c+1; 
end; 
writeln;
  
for i:=1 to n do {Вывод инверсированого массива} 
write(a[i]:4);

close(input);
close(output);
end.
0,0(0 оценок)
Ответ:
Ashmalikova
02.05.2020 19:16
// PascalABC.NET 3.0, сборка 1144 от 16.01.2016
begin
  var a:=ArrRandom(100,-10,10);
  a.Println;
  Writeln(a.Where(x->x>0).Count,' положительных, ',
    a.Where(x->x<0).Count,' отрицательных')
end.

Тестовое решение:
4 -6 0 8 2 -2 -1 -8 -6 8 -3 7 4 -7 -5 9 0 -3 -7 1 0 -4 6 3 8 -10 4 9 3 5 8 5 5 8 10 4 -8 3 8 8 -9 2 7 -8 -7 -5 2 -9 0 9 -7 7 -2 -6 7 -2 -1 7 -10 2 4 1 -1 0 10 3 -8 6 -6 2 6 7 -1 -4 -1 8 0 3 0 2 -2 2 -1 5 1 -9 -4 1 -9 1 -6 -5 3 -4 -7 1 -7 -3 -7 1
51 положительных, 42 отрицательных
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота