GLid
06.12.2021 07:05

Сделать программу на Иван Царевич попал в сад Кащея, где росли молодильные яблоки и ананасы бессмертия. У Ивана с собой была только одна волшебная сумка. Если сумку заполнять полностью яблоками, то в нее поместиться M кг яблок, а если только ананасами, то в нее поместиться N кг ананасов. Яблоки и ананасы можно загружать в сумку вместе в любой пропорции. Килограмм яблок стоит на базаре A рублей, килограмм ананасов – B рублей. Иван собирается лететь на рынок на ковре-самолете, который может унести не более D кг груза, не считая самого Ивана. Какую максимальную сумму (в рублях) может получить Иван Царевич за привезенные фрукты?

Формат ввода
Входные данные содержат на одной строке пять целых чисел через пробел: A, B, M, N, D. Все числа в диапазоне от 0 до 1000.

Формат вывода
Выведите одно число - максимальную сумму в рублях, которую может получить Иван за привезенные на базар фрукты, если продаст их полностью. ответ следует выводить с точностью не менее трех десятичных знаков после запятой

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
DarkLooord
02.07.2022 16:15

Program mathlover12;

const

 n = 6; {Количество элементов массива}

var  

 a:array[1..n] of integer;

s:string;

i,min,max: integer;

begin

 s:=' -=Alphaeus=- ';

 for i:=1 to 22 do begin write(s[i]); sleep(42) end;

{вводим элементы массива}

 writeln; writeln('Введите ',n,' чисел:');

 for i:=1 to n do read(a[i]);

{Ищем min и max}

min:=a[1];

max:=a[1];

 for i:=2 to n do

   begin

     if min>a[i] then min:=a[i];

     if max<a[i] then max:=a[i];

   end;

{Выводим произведение  min и max}

 writeln; writeln;

 writeln('Произведение min и max равнo ',min*max);

end.

0,0(0 оценок)
Ответ:
лчлвоу
12.07.2022 04:43

#include <iostream>

#define N 2

int main()

{

int i,j;

int A[N], B[N], C[N];

setlocale(LC_ALL, "Russian");

for (i = 0; i < N; i++)

{

 std::cout << "Введите a" << i << ": ";

 std::cin >> A[i];

 std::cout << "Введите b" << i << ": ";

 std::cin >> B[i];

 std::cout << "Введите c" << i << ": ";

 std::cin >> C[i];

}

for (i=0;i<N;i++)

 for (j = i+1; j < N; j++)

 {

  if ((A[i]==A[j])&&(B[i] == B[j])&&(C[i] == C[j]))

   std::cout << "Прямые " << i << "и " << j << " совпадают" << std::endl;

  else if (-A[i] / B[i] == -A[j] / B[j])

   std::cout << "Прямые " << i << " и " << j << " параллельны" << std::endl;

 }

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота