nagibator893067TITAN
07.04.2023 11:35

Написать программу на c++. Программа для выбора ребёнком цвета фломастера (Например, при нажатии на 1 на экран выводится Красный, при нажатии на 2 Синий и тд. Нужно 5 цветов)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
НезнайкаЛёша
31.05.2021 19:26
Язык си: 1.

#include

#include

int main(){

   

    int odds_sum=0,odds_cnt=0,

        tdgt_sum=0,mthr_cnt=0;

   

    for(int i=0,n; i< 10; i++){

        scanf("%d",& n);

        if(n%2==1){

            odds_cnt++;

            odds_sum+=n;

        }

        if(9

        if(n%3==0)mthr_cnt++;

    }

   

    printf("%d\n",odds_sum); //сумма нечётных

    printf("%d\n",odds_cnt); //количество нечётных

    printf("%d\n",tdgt_sum); //сумма двузначных

    printf("%d\n",mthr_cnt); //количество кратных трём

   

    return 0;

   

}

2.

#include

#include

int main(){

   

    int even_sum=0,tdgt_sum=0,

        tdgt_cnt=0,ngtv_cnt=0;

   

    for(int i=0,n; i< 20; i++){

        scanf("%d",& n);

        if(n%2==0)even_sum+=n;

        if(9

            tdgt_cnt++;

            tdgt_sum+=n;

        }

        if(n< 0)ngtv_cnt++;

    }

   

    printf("%d\n",even_sum); //сумма чётных

    printf("%d\n",tdgt_sum); //сумма двузначных

    printf("%d\n",tdgt_cnt); //количество двузначных

    printf("%d\n",ngtv_cnt); //количество отрицательных

   

    return 0;

   

}

3.

#include

#include

int main(){

   

    int ngtv_sum=0,ngtv_cnt=0,

        tdgt_sum=0,tdgt_cnt=0;

   

    for(int i=0,n; i< 15; i++){

        scanf("%d",& n);

        if(n< 0){

            ngtv_sum+=n;

            ngtv_cnt++;

        }

        if(99

            tdgt_sum+=n;

            tdgt_cnt++;

        }

    }

   

    printf("%d\n",ngtv_sum); //сумма отрицательных

    printf("%d\n",ngtv_cnt); //количество отрицательных

    printf("%d\n",tdgt_sum); //сумма двузначных

    printf("%d\n",tdgt_cnt); //количество двузначных

   

    return 0;

   

}

0,0(0 оценок)
Ответ:
Каке11
08.09.2022 12:53

program pr10;

uses crt;

var

  i: integer;

  t: real; // рабочая переменная

  i: byte; // счетчик массива

  k: byte; // параметр цикла

  a: array[1..15] of real;

  n: byte; // размерность цикла

begin

  clrscr;

  write('введите размерность: ');

  readln(n);

  writeln('введите ',n,' элементов');

  for i: =1 to n do

      readln(a[i]);

      writeln('исходный массив: ');

  for i: =1 to n do

      write(a[i]: 5: 1,' ');

      readln;

// блок обработки

  for k: =1 to n do

      for i: =1 to n-k do

        if(a[i]> a[i+1]) then

// перестановка

            begin

              t: =a[i];

              a[i]: =a[i+1];

              a[i+1]: =t;

            end;

  writeln('отсортированный массив: ');

  for i: =1 to n do

      write(a[i],' ');

      writeln;

      readln;

end.

я хз как правильно проверить простое число или нет. вот код, который просто сортирует массив по возрастанию.  

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота