незнайка1162
06.10.2020 10:03

Написать программу из 2 частей. в основной программе посчитать сумму факториалов всех нечетных чисел с 1 до 9. подсчет факториалов реализовать в функции

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Gravetalia
01.10.2020 12:59
На Visual Basic с массивом
Sub Program
Dim A(10) As Integer, i As Integer, S As Long
S = 0
For i = 1 To 9 Step 2
A(i) = i
S = S + Fact(A(i))
Next i
Text1.Text = S
End Sub

Function Fact(n)
Dim i As Integer
Fact = 1
For i = 1 To n
Fact = Fact * i
Next i
End Function

Почему во всех институтах изучают Pascal, 
если программы на Basic короче и быстрее работают?
0,0(0 оценок)
Ответ:
kopil199420p017kl
01.10.2020 12:59
Program gt;
var i,s,l:integer;
function IOI(a:integer):integer;
begin
if(a mod 2=1)then IOI:=1 else IOI:=0;
end;
begin
s:=1;
l:=1;
for i:=2 to 9 do
begin
if(IOI(i)=1)then begin
l:=l*i*(i-1);
s:=s+l;
end;
end;
writeln(s);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота