ccfnwj3662
14.12.2021 01:45

Задание на практическую работу Тема: Составление программ с командами цикла.
Цель работы: Научиться составлять программы с циклическими командами.
Порядок выполнения работы:
1.
а) Составить блок- схему вычисления суммы N первых членов последовательности, где
ai =5 I – I2

б) Исполнить алгоритм при N=3
в) Составить программу на Бейсике, реализующую данный алгоритм.

2.
Составить алгоритм в виде блок-схемы и программу на Бейсике вычисления произведения двузначных нечетных чисел от 10 до 20. Исполнить алгоритм

3.
а) Составить блок схему алгоритма получения таблицы значений функции
y = -5 x2 – 3x + 6
если х [0; 15] h = 4

б) Исполнить алгоритм.
в) Составить программу на Бейсике, реализующую данный алгоритм.

4.
а) Составить блок схему алгоритма получения таблицы значений функции у=0,2sin х, если х меньше или = 5; у=2In(х-5) если х больше 5.
если х принадлежит [- 1; 10] h = 4

б) Исполнить алгоритм.
в) Составить программу на Бейсике, реализующую данный алгоритм

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
vorontsovaksus
15.12.2022 08:17
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

№1

begin
  var (a,k):=ReadInteger2('Укажите количество рабочих и служащих:');
  Writeln('Заработок работника равен ',624750/(a+k))
end.

Пример
Укажите количество рабочих и служащих: 15 6
Заработок работника равен 29750

№2

begin
  var y:=ReadReal('Укажите скорость ходьбы, км/ч:');
  var x:=ReadReal('Мальчик пробежал, км: ');
  Writeln('Затрачено времени на бег, ч: ',x/(3*y):0:2)
end.

Пример
Укажите скорость ходьбы, км/ч: 5.2
Мальчик пробежал, км:  12
Затрачено времени на бег, ч: 0.77
0,0(0 оценок)
Ответ:
zharkovaaa1133
15.12.2022 08:17
// PascalABC.NET 3.3, сборка 1627 от 27.01.2018
// Внимание! Если программа не работает, обновите версию!

№1

begin
  var (a,k):=ReadInteger2('Укажите количество рабочих и служащих:');
  Writeln('Заработок работника равен ',624750/(a+k))
end.

Пример
Укажите количество рабочих и служащих: 15 6
Заработок работника равен 29750

№2

begin
  var y:=ReadReal('Укажите скорость ходьбы, км/ч:');
  var x:=ReadReal('Мальчик пробежал, км: ');
  Writeln('Затрачено времени на бег, ч: ',x/(3*y):0:2)
end.

Пример
Укажите скорость ходьбы, км/ч: 5.2
Мальчик пробежал, км:  12
Затрачено времени на бег, ч: 0.77
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота