dl919879
11.12.2020 19:56

Составить программу, которая по введенному числу n печатает фразу «n копеек» в правильной форме (например: «2 копейки», «21 копейка» и т.д.)
На Си++ , с "switch/case"

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
pokintokin
24.11.2021 06:08

a = float(input())

print(a)

count = 0

while a != 1:

   if (a % 2 == 0 or a % 3 == 0):

       if (((a - 1) % 9 == 0) and a % 16 != 0):

           print(a - 1)

           a = (a - 1)/9

           print(a * 3)

           print(a)

           count += 3

       else:

           if ((a - 1) % 32 == 0):

               a = (a - 1)/32

               print(a * 32)

               print(a * 16)

               print(a * 8)

               print(a * 4)

               print(a * 2)

               print(a)

               count += 6

           if (a % 16 == 0):

               a = a/16

               print(a * 8)

               print(a * 4)

               print(a * 2)

               print(a)

               count += 4

           if (a % 16 != 0 and a % 2 == 0):

               a = a/2

               print(a)

               count += 1

           if (a % 9 == 0 or a % 3 == 0):

               a = a/3

               print(a)

               count += 1

   else:

       if a != 1:

           a = a - 1

           print(a)

           count += 1

       if a == 1:

           break

print(count)

В интернете также есть другое решение, где каждый раз считается минимальное значение при исполнении одной из трех операций, и в итоге производится операция, в результате которой число становится наименьшим. То решение неверно, потому что оно упускает многие моменты. Это решение наиболее оптимизировано. Тем не менее, я уверен, что есть сделать его еще более оптимизированным, и что я все же упустил какой-то момент. Особенно важно то, что если у нас число, к примеру, 28 (то есть вида 3^n + 1, в данном случае n = 3), то рациональнее отнять от него 1 и делить три раза на 3, чем сразу делить на 2. Если отнять 1 и делить на 3, то это займет всего 4 операции (28 -> 27 -> 9 -> 3 -> 1). А если на 2 (28 -> 14 -> 7 -> 6 -> 3 -> 2 -> 1), то целых 6 операций.

Но в случае с числами, вроде 1000000 (т.е с числами, которые делятся хотя бы на четвертую степень двойки 2^4 = 16), гораздо рациональнее сразу делить на 2, чем отнимать единицу и делить на 3. Я не буду расписывать полностью, но в случае деления на 3 потребуется 25 операций, а с делением на 2 - всего 19.

0,0(0 оценок)
Ответ:
alechka7
24.11.2021 06:08

a = float(input())

print(a)

count = 0

while a != 1:

   if (a % 2 == 0 or a % 3 == 0):

       if (((a - 1) % 9 == 0) and a % 16 != 0):

           print(a - 1)

           a = (a - 1)/9

           print(a * 3)

           print(a)

           count += 3

       else:

           if ((a - 1) % 32 == 0):

               a = (a - 1)/32

               print(a * 32)

               print(a * 16)

               print(a * 8)

               print(a * 4)

               print(a * 2)

               print(a)

               count += 6

           if (a % 16 == 0):

               a = a/16

               print(a * 8)

               print(a * 4)

               print(a * 2)

               print(a)

               count += 4

           if (a % 16 != 0 and a % 2 == 0):

               a = a/2

               print(a)

               count += 1

           if (a % 9 == 0 or a % 3 == 0):

               a = a/3

               print(a)

               count += 1

   else:

       if a != 1:

           a = a - 1

           print(a)

           count += 1

       if a == 1:

           break

print(count)

В интернете также есть другое решение, где каждый раз считается минимальное значение при исполнении одной из трех операций, и в итоге производится операция, в результате которой число становится наименьшим. То решение неверно, потому что оно упускает многие моменты. Это решение наиболее оптимизировано. Тем не менее, я уверен, что есть сделать его еще более оптимизированным, и что я все же упустил какой-то момент. Особенно важно то, что если у нас число, к примеру, 28 (то есть вида 3^n + 1, в данном случае n = 3), то рациональнее отнять от него 1 и делить три раза на 3, чем сразу делить на 2. Если отнять 1 и делить на 3, то это займет всего 4 операции (28 -> 27 -> 9 -> 3 -> 1). А если на 2 (28 -> 14 -> 7 -> 6 -> 3 -> 2 -> 1), то целых 6 операций.

Но в случае с числами, вроде 1000000 (т.е с числами, которые делятся хотя бы на четвертую степень двойки 2^4 = 16), гораздо рациональнее сразу делить на 2, чем отнимать единицу и делить на 3. Я не буду расписывать полностью, но в случае деления на 3 потребуется 25 операций, а с делением на 2 - всего 19.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота