sodemAN2
10.09.2020 13:29

У нас есть бизнес-план! Пункт первый: надо написать программу-гороскоп, которая по некоторым простым вопросам выдаёт строго индивидуальный анализ личностных качеств. Мы будем делать это по передовым астрологическим методикам. Напишите программу, которая считывает с клавиатуры последовательно: имя, фамилию, любимое животное, знак зодиака.

После этого программа выводит:

Индивидуальный гороскоп для пользователя [имя] [фамилия]
Кем вы были в жизни: [любимое животное]
Ваш знак зодиака - [знак зодиака] , поэтому вы - тонко чувствующая натура.

Уточнение: слова про тонко чувствующую натуру выводятся абсолютно всегда, независимо от того, что именно вводил пользователь (это пародия на процесс составления «реального» гороскопа). В один и тот же фиксированный текст подставляются те слова, которые вводил пользователь.

Пробел перед запятой по правилам, конечно, не ставится, но здесь пусть стоит.

Пример
Ввод Вывод
Иван
Кузнецов
лис
овен
Индивидуальный гороскоп для пользователя Иван Кузнецов
Кем вы были в жизни: лис
Ваш знак зодиака - овен , поэтому вы - тонко чувствующая натура.
История решений
Добавить комментарий

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Anastasia2416
15.08.2020 04:15

pascal

Объяснение:

procedure sortmas(a: array of integer);

var i, j, min, ind: integer;

begin

 for i := 0 to Length(a) - 2 do

 begin

   min := a[i]; ind := i;

   for j := i + 1 to Length(a) - 1 do

     if a[j] < min then

     begin

       min := a[j]; ind := j;

     end;

   a[ind] := a[i]; a[i] := min;

 end;

end;

var a: array of integer;

   n , i: integer;

begin

 WriteLn('Введите размер массива: '); Read(n);

 SetLength(a, n);

 Randomize;

 WriteLn('Содержимое массива:');

 for i := 0 to Length(a) - 1 do

 begin

   a[i] := random(100);

   Write(a[i], ', ');

 end;

 WriteLn;

 sortmas(a);

 WriteLn('Три минимальных элемента: ', a[0], ', ', a[1], ', ', a[2], ', ');

end.

0,0(0 оценок)
Ответ:
Dangssa
08.12.2022 11:48

pascal

Объяснение:

procedure sortmas(a: array of integer);

var i, j, min, ind: integer;

begin

 for i := 0 to Length(a) - 2 do

 begin

   min := a[i]; ind := i;

   for j := i + 1 to Length(a) - 1 do

     if a[j] < min then

     begin

       min := a[j]; ind := j;

     end;

   a[ind] := a[i]; a[i] := min;

 end;

end;

var a: array of integer;

   n , i: integer;

begin

 WriteLn('Введите размер массива: '); Read(n);

 SetLength(a, n);

 Randomize;

 WriteLn('Содержимое массива:');

 for i := 0 to Length(a) - 1 do

 begin

   a[i] := random(100);

   Write(a[i], ', ');

 end;

 WriteLn;

 sortmas(a);

 WriteLn('Три минимальных элемента: ', a[0], ', ', a[1], ', ', a[2], ', ');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота