Olgadaleewa
30.06.2022 09:23

Составить программу суммирования натуральных чисел пока их сумма не превысит величину h. вывести на экран последнее слагаемое и сумму

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
валера200331
24.06.2020 21:44
Readln(n,h);
for i:=1 to n do begin
s:=s+i;
if s>h then
break;
end;
writeln(i,s);
0,0(0 оценок)
Ответ:
adam83
24.06.2020 21:44
Uses crt;
var n,h,i,sum:integer;
begin
read(n,h);
while sum<=h do
begin
sum+=i;
i+=1;
end;
writeln(i-1,' ',sum-i);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота