Mokikoo
06.07.2020 09:33

, Составить программу расчета конечной суммы 1+2+3+4+...+N. Полученный результат сравнить с контрольным значением по формуле N(N+1)/2. Количество слагаемых N вводится с клавиатуры.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Islikzaziy
26.09.2020 22:18
Const
  n = 10;

var
  a: array[0..10] of integer;
  i, s: integer;

begin

//Заполнение массива сл. числами

  for i := 1 to n do
  begin
    a[i] := random(201) - 100;
    write(a[i]:4);
  end;
  writeln;

//1) Все элементы не превышающие число 100

  writeln('Не больше 100 ');
  for i := 1 to n do
    if a[i] <= 100 then
      write( a[i]:4);
  writeln;

// 2) Все четные элементы

  writeln('Кратные двум ');
  for i := 1 to n do
    if a[i] mod 2 = 0 then  
      write( a[i]:4);
  writeln;

// 3) Все элементы, являющиеся трехзначными числами

   writeln('Трехзначные ');
  for i := 1 to n do
    if (a[i] < -99) or (a[i] > 99) then  
      write(a[i]:4);
  writeln;

// 4) Третий, шестой и т.д элементы.

  i := 3;
  writeln(' номера 3, 6, 9 и  т.д.');
  while i < n do
  begin
    write(a[i]:4);
    i := i + 3;
  end;
end.
0,0(0 оценок)
Ответ:
KaKOYTAGHOM
09.11.2020 10:52

При автоматическом переводе могут возникнуть много проблем

в зависимости от контекста слова могут иметь разное значениеперевод пословиц, поговорок и прочих стандартных словосочетаний может не существовать на другом языке или может быть передан не верноотрицательные предложения могут перейти в положительныеигра слов часто непереводиманедостаток информации одного текста не может быть восполнен. Например в английском у глаголов нет родов, а в русском естьдругая причина потери смыслаэлектронный переводчик может не знать, как переводится слово или фраза, или не иметь всех вариантов перевода
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота