igorzarubin2006
29.11.2020 04:17

написать программу на Паскале. Цель следующая: Задана последовательность: a_{1} =1, a_{n} = a_{n-1} + n^{2}
Какое наименьшее количество членов последовательности нужно сложить, чтобы сумма стала больше 1000?
Желательно использовать цикл for или repeat.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Рикания
12.01.2021 23:02
#include <iostream>

using namespace std;

int main() {
    int i,n,k;
    cout<<"Vvedite chislo elementov massiva: ";
    cin>>n;
    int a[n];
    for (i=0; i<n; i++){
        cout<<"Vvedite "<<i+1<<"-e chislo massiva: ";
        cin>>a[i];
    }
    cout<<"Vvedite znachenie k: ";
    cin>>k;
    int m=0;
    for(i=0;i<n;i++) if (abs(a[i])>2*k) m++;
    cout<<"Naydeno elementov: "<<m<<"\n";
    system("pause");
    return 0;
}

Тестовое решение:

Vvedite chislo elementov massiva: 6
Vvedite 1-e chislo massiva: -7
Vvedite 2-e chislo massiva: 2
Vvedite 3-e chislo massiva: 0
Vvedite 4-e chislo massiva: -5
Vvedite 5-e chislo massiva: 8
Vvedite 6-e chislo massiva: 3
Vvedite znachenie k: 2
Naydeno elementov: 3
Для продолжения нажмите любую клавишу . . .
0,0(0 оценок)
Ответ:
tka4ukilia2017
23.09.2022 06:13
1.а) количество тетрадей - вещественный тип
Нет, так как в вещественном типе задается количество с запятыми, а тетради  - это целое количество,т.е целый тип.
б) кличка собаки - символьный тип
Да
Вполне возможно, значение символьных величин - набор символов 
кличку собаки можно взять в ковычки, т.к все символьные элементы берутся в кавычки.
в) вес контейнера - целый тип
Нет
т.к целый тип подразумевает целое число, а контейнер может весить и ,например, 15,1кг граммы все равно будут.
2. а) Символьный
б) Целый
в) Вещественный
3.Символьный(литерный ,строковый ) подразумевает одно и тоже.
‘55’ ; - а
 30; - а
-46; - д
 -0.126; - б
 ‘солнце’; - в
 15.003; - б 
‘g’ -г
4. а)постоянная
б) Постоянная
в)Постоянная (сколько я помню, в январе всегда 31 день.)
г)Переменная
5. а)Целый
б)Символьный
в) Целый
6. 293,123
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота