ПитерДина
20.04.2021 13:15

Составьте программу вычисления произведения простых делителей натурального числа n.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
LediLizonka
01.10.2020 12:54
var
x,i,n: integer;
begin
x:=1;
write('Введите натуральное число: ');
read(n);
write('Простые делители числа ',n,': ');
for i:= 1 to n do
 if n mod i = 0 then
  begin
  write(i:4);
  x:=x*i;
  end;
writeln;
writeln('Их произведение: ',x);
end. 
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота