Написать программу для сложения а и в в троичной системе счисления. числа а и в хранятся в первой строке входного файла exemp.in их сумма в троичной системе-в выходном файле exemp5.out
Program chik; var a,b,q,s1,s2,s:longint; begin read(a,b); s1:=0; while a>0 do begin q:=a mod 3; a:=a div 3; s1:=s1*10+q; end; s2:=0; while b>0 do begin q:=b mod 3; b:=b div 3; s2:=s2*10+q; end; s:=s1+s2; writeln(s); end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку