alexa7021
06.03.2020 12:57

PASCALABC.NET В массиве хранится информация об отметках 20 учащихся за контрольную работу(случайные числа от 1 до 10).Составьте программу,которая вычисляет количество учащихся,получивших неудовлетворительные отметки(0,1,2).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Никита50005
09.10.2021 01:20

program izi;

   var mass:array [1..20] of integer;

   i,n:integer;

begin

   randomize;

   for i:= 1 to 20 do

       mass[i]:= random (10);

   for i:= 1 to 20 do

       write (mass[i],' | '); //оценки учеников

   n:=0;

   for i:= 1 to 20 do  

       if mass[i] <= 2 then

           n:= n+1;

   writeln;

   writeln ('Количество учеников, получивших "плохие" отметки(0,1,2): ',n);

end.

       

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота