datskivvera1
20.11.2022 18:54

Составьте программу нахождения наибольшего общего делителя для двух чисел. (воспользоваться алгоритмом евклида). алгоритм евклида поиска наибольшего общего делителя двух чисел: вычитай из большего меньшее, пока числа не станут равны. полученное значение и будет искомым.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
meloo1
24.06.2020 16:25
Var  a, b: word;
function NOD(x, y: integer):integer;
begin 
repeat    
 if abs(x) > abs(y) then      
 x := x mod y    
else    
  y := y mod x;  
until (x = 0) or (y = 0); 
  NOD := abs(x + y);
 end;
begin 
 write('a=');read(a);  
 write('b=');readln(b); 
writeln('NOD(a,b)=', NOD(a, b)); 
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота