ksenia20062
04.10.2020 07:59

Нужно исправить блок схему и написать программу на qbasic

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Daniluha29
29.04.2021 08:19
#include <iostream>
#include <vector>
using namespace std;

int main() {
    unsigned short int n;
    cout << "n = ";
    cin >> n;
    vector<int> a;
    int in,
        avg,
        s = 0,
        c = 0;
    for (int i = 0; i < n; ++i) {
        cout << "a[" << i << "] = ";
        cin >> in;
        a.insert(a.end(), in);
        if (i % 2 == 1) {
            s += a.back();
            c++;
        }
    }
    avg = (int) s / c;
    cout << "Среднее арифметическое элементов на нечётных позициях: "
         << avg;
    return 0;
}
0,0(0 оценок)
Ответ:
89269705621
21.01.2023 12:27

Вычитание выполнено в шестеричной системе счисления.

Объяснение:

Мы видим в данном выражении цифры до 4. Из этого следует, что система счисления использует не менее 5 цифр. То есть, она как минимум - пятиричная. Будем подбирать по порядку системы счисления и вычислять их значения.

Пятиричная система счисления:

1. Переводим в десятичную систему счисления:

102 = 25 * 1 + 5 * 0 + 1 * 2 = 25 + 0 + 2 = 27

14 = 5 * 1 + 1 * 4 = 5 + 4 = 9

2. Вычисляем в десятичной системе счисления:

27 - 9 = 18

3. Переводим в пятиричную систему счисления:

18 = 33

Вывод: данная система счисления не подходит.

Шестеричная система счисления:

1. Переводим в десятичную систему счисления:

102 = 36 * 1 + 6 * 0 + 1 * 2 = 36 + 0 + 2 = 38

14 = 6 * 1 + 1 * 4 = 6 + 4 = 10

2. Вычисляем в десятичной системе счисления:

38 - 10 = 28

3. Переводим в шестеричную систему счисления:

28 = 44

Вывод: данная система счисления подходит.

УДАЧИ! ОБРАЩАЙТЕСЬ!
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота