dali666
15.10.2020 07:22

Составьте программу заполнения массива a [1...10] числами Фибоначчи. В последовательности Фибоначчи первый элемент равен нулю, второй - единице, а каждый элемент, начиная с третьего, равен сумме двух предыдущих.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Lady2575
05.10.2021 01:00

pascal

Объяснение:

var

  x, y, i: integer;

  a: array[1..10] of integer;

begin

 x := 1; y := 1; a[2] := 1;

 for i := 3 to 10 do

 begin

    y := x + y; x := y - x; a[i] := y;

 end;

 for i := 1 to 10 do Write(a[i], ', ');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота