Dubrov5ky
24.01.2020 12:29

Нужно составить программу и процедуру по данному рисунку , нужно сдать уже завтра


Нужно составить программу и процедуру по данному рисунку , нужно сдать уже завтра

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Vbeker
05.10.2021 20:48

string a;

string b;

int count = 0;

int count2 = 0;

bool g = false;

bool g2 = false;

Console.WriteLine("Введите первую строку");

a = Convert.ToString(Console.ReadLine());

Console.WriteLine("Введите первую строку");

b = Convert.ToString(Console.ReadLine());

Console.WriteLine("Введите первый символ");

Макрой avatar

char first_symbol = Convert.ToChar(Console.ReadLine());

Console.WriteLine("Введите последний символ");

char second_symbol = Convert.ToChar(Console.ReadLine());

char[] separ = { ' ' };

string[] a1 = a.Split(separ);

string[] b1 = b.Split(separ);

Макрой avatar

for (int i = 0; i < a1.Length; i++)

if (a1[i].IndexOf(first_symbol) == 0 && a1[i].IndexOf(second_symbol) == a1[i].Length - 1)

{

Console.Write(a1[i]+";"); count++; g= true;

}

if (g)

{

Console.WriteLine(" В этой строке :" + count + " слов(о)");

}

Console.WriteLine();

Макрой avatar

for (int i = 0; i < b1.Length; i++)

if (b1[i].IndexOf(first_symbol) == 0 && b1[i].IndexOf(second_symbol) == b1[i].Length - 1)

{

Console.Write(b1[i]+";"); count2++; g2 = true;

}

if (g2)

{

Console.WriteLine(" В этой строке :" + count2 + " слов(о)");

}

Console.ReadLine();

Объяснение:

0,0(0 оценок)
Ответ:
Вазген228
25.02.2023 15:51
1.                                                            

program raf105;

var  

 i,n,a: integer;

begin

 write('Введите число: ');

 readln(a);

 write('Введите количество повторений: ');

 readln(n);

 for i:=1 to n do

   writeln(a);

end.

2.                                                            

program raf105;

var  

 sum,i: integer;

begin

 for i:=10 to 99 do

   if i mod 2 = 0

     then sum:= sum+i;

 writeln('Сумма всех чётных двузначных чисел: ',sum);

end.

3.                                                            

program raf105;

var  

 x,y: real;

begin

x:= -2;

 while x <= 2 do

 begin

   y:= 2*x+3;

   writeln(x:4:1,' ',y:4:1);

   x:= x+0.2

 end;

end.

                                                              PascalABC 3.4.2
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота