Alisacollins1
18.05.2021 02:02

Решить на C++ Вид треугольника
Напишите программу, которая принимает три положительных числа и определяет вид треугольника, длины сторон которого равны введенным числам.

Формат входных данных
На вход программе подаются три числа – длины сторон существующего треугольника.

Формат выходных данных
Программа должна вывести на экран текст – вид треугольника («Равносторонний», «Равнобедренный» или «Разносторонний»).

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Kiss537
03.10.2021 07:30

#include <iostream>

using namespace std;

int main()

{

setlocale(0, "");

int a{}, b{}, c{};

cin >> a >> b >> c;

if (a == b && a == c)

cout << "Равносторонний";

else if (a == b || a == c || b == c)

cout << "Равнобедренный";

else

cout << "Разносторонний";

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота