EvgenyMalkin71
30.10.2022 20:39

, составить программу в Scratch Дано целое число N и набор из N целых чисел. Найти номера первого и
последнего минимального элемента из данного набора и вывести их в
указанном порядке.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
SKIRLES
02.05.2022 20:19

#include <iostream>

#include <time.h>

#include <iomanip>

using namespace std;

int main()

{

 int a[20];

 int i, ibeg, iend, s;

 setlocale(LC_ALL, "Russian");

 srand(time(NULL));

 for (i = 0; i < 20; i++) {

   a[i] = (double)rand() / (RAND_MAX + 1) * 10;

   cout << a[i] << " ";

 }

 ibeg = -1;

 for (i = 0; i < 20; i++) {

   if (a[i] == 0) {

     ibeg = i;

     break;

   }

 }

 iend = -1;

 for (i = 20; i > 0; i--) {

   if (a[i] == 0) {

     iend = i;

     break;

   }

 }

 if (ibeg != -1 && iend != -1) {

   s = 0;

   for (i = ibeg + 1; i < iend; i++)

     s += a[i];

   cout << "\nСумма = " << s << "\n";

 }

 else

   cout << "\nНулевые элементы не найдены.\n";

}

0,0(0 оценок)
Ответ:
Elenka9272
16.07.2021 20:52

Для перевода десятичного числа в двоичную систему его необходимо последовательно делить на 2 до тех пор, пока не останется остаток, меньший или равный 1

52

Нормализованная экспоненциальная запись числа – это запись вида

a = ± m * P^(q)

Где q – целое число (положительное, отрицательное или ноль) m – правильная Р-ичная дробь, у которой целая часть состоит из одной цифры, при этом m – это мантисса числа, а q – порядок (или экспонента) числа.

В нашем случае:

1,6898*10^-3

Для перевода десятичного числа в восьмеричную систему его необходимо последовательно делить на 8 до тех пор, пока не останется остаток, меньший или равный 7. Число в восьмеричной системе записывается как последовательность цифр последнего результата деления и остатков от деления в обратном порядке.

1616

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота