Юли009
04.03.2020 18:09

C++
написать программу (1 номер )


C++ написать программу (1 номер )

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
aish17
23.04.2020 00:39

//Я так понял, что под порядком "неубывания" вы имеете ввиду порядок возрастания...

//Поскольку вы не указали исходный массив, я его сгенерировал, а также вывел на экран, чтобы можно было проверить результаты


const

  size = 10;

  x = -100;

  y = 100;

   

var

  arr: array[1..size] of integer;

  counter, sum, positiveNumbers, negativeNumbers: integer;

  increase: boolean;

   

begin

  randomize;

   

  counter := 0;

  sum := 0;

  positiveNumbers := 0;

  negativeNumbers := 0;

  increase := true;

   

  writeln('Массив:');

   

  for var i := 1 to size do

  begin

     arr[i] := random(x, y);

     writeln(i, ') ', arr[i]);

     

     if (arr[i] > 0) then

     begin

        counter := counter + 1;

        positiveNumbers := positiveNumbers + 1;

        sum := sum + arr[i];      

     end

     

     else

        negativeNumbers := negativeNumbers + 1;

  end;

   

  writeln();

   

  if (counter > 0) then

     writeln('1) Среднее арифметическое всех положительных элементов массива = ', sum / counter)

   

  else

     writeln('1) Положительных элементов массива не было (0)');

     

  if (positiveNumbers > negativeNumbers) then

     writeln('2) В массиве больше положительных элементов')

     

  else if (positiveNumbers = negativeNumbers) then

     writeln('2) В массиве одинаковое количество положительных и отрицательных элементов')

     

  else

     writeln('2) В массиве больше отрицательных элементов');

     

  for var j := 1 to size - 1 do

  begin

     if (arr[j] > arr[j + 1]) then

     begin

        increase := false;

        break;

     end;

  end;

   

  if (increase) then

     writeln('3) Элементы расположены в порядке возрастания')

     

  else

     writeln('3) Элементы не расположены в порядке возрастания');

end.


по информатике! паскаль! 1) найти среднее арифметическое всех положительных элементов массива или вы
по информатике! паскаль! 1) найти среднее арифметическое всех положительных элементов массива или вы
по информатике! паскаль! 1) найти среднее арифметическое всех положительных элементов массива или вы
0,0(0 оценок)
Ответ:
VAR
   ans: Real;
   n, i, j, kol: Integer;
   a: Array of Array of Real;
BEGIN
   Read(n); SetLength(a, n+1);
   For i := 1 to n do SetLength(a[i], n+1);

   For i:= 1 to n do 
      For j := 1 to n do Read(a[i][j]);

   For i := 1 to n do
      If (a[i][i] > 0) then begin Inc(kol); ans := ans + a[i][i]; End;

   If (kol > 0) then begin Writeln('Ср. ар. с гл. диагонали = ', ans / kol); kol := 0;ans := 0; End
   Else Writeln('Элементов > 0 на гл. диагонали - нет !');

   For i := 1 to n do
      If (a[i][n-i+1] > 0) then begin Inc(kol); ans := ans + a[i][n-i+1]; End;

   If (kol > 0) then Writeln('Ср. ар. с поб. диагонали = ', ans / kol)
   Else Writeln('Элементов > 0 на поб. диагонали - нет !');
END.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота