sveta465
22.02.2023 03:00

Напишите программу на языке С, чтобы выполнить следующие операции...

Задайте четыре числа. Выстроите их в порядке невозрастания. С оператора if/else проверьте условие, при котором, если эти числа представляют собой отрезки, то можно ли из этих отрезков собрать прямоугольник. Проверьте, не является ли полученный прямоугольник квадратом. Вычислите периметр и площадь, образованной фигуры.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
лалалалад1
02.03.2020 15:25

1) 

var a:array [1..100] of integer;

n,i:integer;

begin

for i:=10 to 99 do begin

a[i]:=i;

if (a[i] mod n=0) then writeln(a[i]);

end;

end.

 

 2)

var a:array [1..100] of integer;

n,k,i,x,y,z: integer;

begin

readln(n,k);

for i:=n to k do begin

a[i]:=i;

x:=a[i] mod 10;

y:=a[i] div 10;

z:=y mod 10;

y:=y div 10;

if (x=y) or (x=z) or (y=z) then writeln(a[i]);

end;

end.

 

 3)

 var a,n,an,na: integer;

begin

readln(a,n);

if (a>0) and (b>0) then begin

an:=a*10+n;

na:=n*10+a else writeln('Введены неверные числа!');

end;

end.

0,0(0 оценок)
Ответ:
VeZun4ik
02.03.2020 15:25
Разница в объеме хранимой информации, сходство с записиСходства-одинаковые размеры (диаметр 120 мм, толщина 1.6 мм), тот же радужный вид. Принцип записи и чтения тоже аналогичный: лазерный луч отражается от металлизированной поверхности ("ямок" и "горок"), причем, отражение от любой поверхности кодирует ноль, а отражение от перехода между ямкой и горкой (при этом луч ослабляется за счет интерференции) - единицу 
На этом сходство заканчивается - дело в том, что в CD используется инфракрасный лазер (длина волны в воздухе 780 нм). В DVD же применяется красный лазер (650/635 нм). Меньшая длина волны позволяет плотнее размещать информацию на DVD-диске. 
Ёмкость DVD сильно превосходит обычный компакт-диск (640 Мб) и составляет 4.38 гигабайта (в смысле 2^30 байт) или 4.7 миллиарда байт, имеется в виду односторонний, однослойный DVD-диск
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота