Кндр15
11.04.2023 15:11

Написать программу в паскале, чтобы на выходе получть: сколько раз за февраль температура была> 0, первую дату , когда она повысилась> 0, количество дней, когда температура отличалась от средней не более чем на 1 (температура вводится рандомно)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Savelijbih
03.03.2022 08:37
function ptcrk(a,b,x,y,r: real): integer;
var k: integer;
begin
  k:=0;  
  if abs(sqr(x-a)+sqr(y-b)-r*r)<1.0e-9 then k:=1;
  if r*r-sqr(x-a)-sqr(y-b)>1.0e-9 then k:=2;
  ptcrk:=k;
end;
// основная программа
var a,b,x,y,r,k: real;
begin
  write('координаты центра a b: ');  readln(a,b);
  write('координаты точки x y: ');  readln(x,y);
  write('радиус: ');  readln(r);
  k:=ptcrk(a,b,x,y,r);
  if k=1 then writeln('точка на окружности');
  if k=2 then writeln('точка внутри круга');
  if k=0 then writeln('точка вне круга');
end.

координаты центра a b: 2 1
координаты точки x y: 4 1
радиус: 2.1
точка внутри круга

координаты центра a b: 2 1
координаты точки x y: 4 1
радиус: 2
точка на окружности
0,0(0 оценок)
Ответ:
averinatatka
11.09.2020 00:52
Линейный - самый простой. Например, измерить стороны прямоугольника и найти его периметр.
Начало - Измерить ширину, длину - Удвоить сумму длины и ширины - Записать ответ-периметр - Конец

Разветвляющийся - имеет условие, две "ветки". Ситуация на перекрестке.
Начало - Подошли к перекрестку - Горит зеленый свет? -
         ветка "да": перейти дорогу
         ветка "нет": стоять и ждать зеленый свет
- Конец

Цикл означает повтор какого-то действия, например, покраска стены.
Начало - Подойти к стене и взять кисть и краску -
         начало цикла: обмакнуть кисть в краску и провести по стене,
         пока вся стена не будет закрашена
- Убрать кисть и краску на место  - Конец
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота