лера21091
09.04.2022 20:26

Задача Python X мальчиков и Y девочек пошли в кинотеатр и купили билеты на подряд идущие места в одном ряду. Напишите программу, которая выдаст, как нужно сесть мальчикам и девочкам, чтобы рядом с каждым мальчиком сидела хотя бы одна девочка, а рядом с каждой девочкой — хотя бы один мальчик.

На вход подаются два числа - кол-во мальчиков X и кол-во девочек Y. В ответе выведите какую-нибудь строку, в которой будет ровно X символов “B” (обозначающих мальчиков) и Y символов “G” (обозначающих девочек), удовлетворяющую условию задачи. Пробелы между символами выводить не нужно. Если рассадить мальчиков и девочек согласно условию задачи невозможно, выведите строку “Нет решения”.

Пример 1:

Введите кол-во мальчиков: 5
Введите кол-во девочек: 5
ответ: BGBGBGBGBG
Пример 2:

Введите кол-во мальчиков: 5
Введите кол-во девочек: 3
ответ: BGBGBBGB
Пример 3:

Введите кол-во мальчиков: 100
Введите кол-во девочек: 1
ответ: Нет решения

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
dariapark1
13.09.2021 22:30

X = int(input('Введите кол-во мальчиков: '))

Y = int(input('Введите кол-во девочеке: '))

string = ''

if  X > Y:

   if X / Y <= 2:

       for _ in range(Y):

           string += 'BG'

       string = string.replace('BG', 'BGB', X-Y)

   else:

       string = 'Нет решений!'

else:

   if Y / X <= 2:

       for _ in range(X):

           string += 'GB'

       string = string.replace('GB', 'GBG', Y-X)

   else:

       string = 'Нет решений!'

print(string)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота