ygorbrusnyak
29.06.2020 13:49

Всем привет написать программу на Pascal, можно с циклом. Условие: пользователь спрашивает какую-нибудь фразу. Если вводить неправильную фразу, пользователь ещё раз спросит эту фразу. Если правильно ввести фразу, он повторит её 100 раз.
Заранее !

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Sonni18
23.03.2021 01:01

#include <iostream>

using namespace std;

int main(){

   int n, count = 0, suma = 0;

   cout<<"Vvesti kolichestvo elementow massiva\n";

   cin>>n;

   int arr[n];

   cout<<"Vvesti elementy massiva\n";

   for (int i = 0; i < n; ++i) {

       cin>>arr[i];

   }

   for (int i = 0; i < n; ++i) {

       if (arr[i]%5==0){

           count ++;

           suma += arr[i];

       }

   }

   cout<<"Kolichestvo elementov kratnyh 5 = "<<count<<endl;

   cout<<"Summa elementov kratnyh 5 = "<<suma<<endl;

}

Объяснение:

Создаем переменную n которая будет определять количество элементов в массиве.  Потом объявляем переменные count(подсчет элементов кратным 5) и suma(аналогично).

Вводим количество элементов массива и заполняем сам массив.

Далее идет цикл и в нем условие "Если элемент массива при делении на 5 дает остаток 0(то есть число кратное 5) то..."

В условии к count добавляем 1 элемент каждый раз, когда условие правдиво.

К суме добавляем сам элемент, в том же случае.

Ну и выводим эти переменные

0,0(0 оценок)
Ответ:
anna4513
06.06.2021 23:08

задание 1:

использовать Робот

алг

нач

цел с=0

нц

вверх

если слева стена то закрасить; с:=1 всё

кц при с=1 и слева свободно

нц пока снизу свободно

если слева стена то с:=1 иначе с:=0 всё

вниз

если с=1 и слева стена то закрасить всё

кц

нц

если снизу свободно то с:=0 всё

вправо

если снизу стена то

закрасить

если с=0 то с:=2 всё

всё

кц при с=2 и снизу свободно

кон

задание 2:

использовать Робот

алг

нач

цел с=0

нц

влево

если сверху стена то закрасить; с:=1 всё

кц при с=1 и сверху свободно

нц пока справа свободно

если сверху стена то с:=1 иначе с:=0 всё

вправо

если с=1 и сверху стена то закрасить всё

кц

нц

если справа свободно то с:=0 всё

вниз

если справа стена то

закрасить

если с=0 то с:=2 всё

всё

кц при с=2 и справа свободно

кон


Составьте, , программы для робота в кумире на 2 . ​
Составьте, , программы для робота в кумире на 2 . ​
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота