Фариза1111111
03.04.2020 19:46

Задание 5. Составьте программу, которая генерирует случайное четы- рехзначное число от 1000 до 9999 (номер автобусного билета), выводит его на экран и определяет, является ли билет «счастливым» (сумма первых двух цифр равна сумме последних двух цифр). ВНИМАНИЕ ЯЗЫК ПАСКАЛЬ

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
virtuspro2000
25.11.2021 11:56

var

 n:integer;

begin

 n:=random(9000)+1000;

 writeln(n);

 if n div 1000 + n div 100 mod 10 = n mod 10 + n mod 100 div 10 then

   writeln('Happy ticket')

     else writeln('ps');

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота