Yanawer
01.04.2022 10:09

Впаскале сформирвать массив из десяти элементов, заполнить его с генератора случайных чисел и сделать так, чтобы в нем поменялись местами 1 и 2, 3 и 4 значение и так далее. нужно написать программу.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Мандариин1335
23.06.2020 23:42
Program Task;
Var a: Array [1..10] of Integer;
    i, tmp: Integer;
Begin
    Randomize;
    WriteLn('Сформированный массив:');
    For i := 1 To 10 Do
    Begin
        a[i] := Random(10);
        Write(a[i], ' ');
    End;
    WriteLn;
    For i := 1 To 5 Do
    Begin
        tmp := a[i * 2];
        a[i * 2] := a[i * 2 - 1];
        a[i * 2 - 1] := tmp;
    End;
    WriteLn('Измененный массив:');
    For i := 1 To 10 Do
        Write(a[i], ' ');
    ReadLn;
End.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота