katelove8
08.01.2020 16:42

решить нужно на языке программирования С, либо С++ Напишите программу, которая определяет, сколько раз встречается в матрице элемент, равный K .
Входные данные
В первой строке записаны через пробел размеры матрицы: количество строк N и количество столбцов M ( 1 ≤ N , M ≤ 100 ). В следующих N строках записаны строки матрицы, в каждой – по M натуральных чисел, разделённых пробелами. В следующей строке записано целое число K .
Выходные данные
Программа должна вывести количество элементов матрицы, равных K .

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
вита1404
04.11.2022 09:04
Я не трус, но я боюсь!
(Бриллиантовая рука)

Да нам, царям, молоко нужно выдавать за вредность!
(Иван Васильевич меняет профессию)

Этот нехороший человек предаст нас при первой же опасности!
(Джентльмены удачи)

Бамбарбия! Киргуду! Шутка!
(Кавказская пленница)

Шурик, это же не наш метод!
(Операция Ы и другие приключения Шурика)

Восток – дело тонкое.
Белое солнце пустыни

Утром деньги – вечером стулья, вечером деньги – ночью стулья…
(двенадцать стульев)

он, конечно, виноват, но он… не виноват…
(Берегись автомобиля!)
0,0(0 оценок)
Ответ:
Velichkovskaya
13.10.2020 02:47
#include <iostream>
using namespace std;

int main() {
    int n=10,k=0;
    int a[n];
    srand(time(NULL));
    cout<<"array:"<<endl;
    for (int i=0; i<n; i++)
    {
      a[i]=rand() % 6;
      cout<<a[i]<<" ";
    }
    cout<<endl;
    for (int i=0; i<n-1; i++)
    if (a[i]==a[i+1])  {
    k++;
    if (k==1) cout << "Есть: ";
    cout<<a[i]<<" ";
    }
    if (k==0) cout << "нет";
    system("pause");
    return(0);
}

Пример:
array:
0 5 5 0 2 5 2 4 0 5
Есть: 5
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота