alina050804alina
04.11.2021 17:52

3: Напишите программу на языке Python. В программе случайным образом вводятся 20 положительных и отрицательных чисел в диапазоне от -10 до 10. a) вычислить произведение всех ненулевых чисел
b) найти количество отрицательных чисел
c) найти количество положительных чисел
d) определить каких чисел больше положительных или отрицательных

Вывести ответ в следующем формате:
Произведение чисел =
Количество положительных чисел =
Количество отрицательных чисел =
Больше чисел на

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
toktasynnazerke
04.10.2021 01:10

from random import randint

random_numbers = [randint(-10, 10) for x in range(20)]

print(random_numbers)  # show all random numbers list

positive_numbers = [n for n in random_numbers if n > 0]

negative_numbers = [n for n in random_numbers if n < 0]

print("Произведение чисел = {}".format(sum(positive_numbers)))

print("Количество положительных чисел = {}".format(len(positive_numbers)))

print("Количество отрицательных чисел = {}".format(len(negative_numbers)))

print("Больше {} чисел на {}".format(

   'положительных' if len(positive_numbers) > len(negative_numbers) else 'отрицательных',

   abs(len(positive_numbers) - len(negative_numbers

0,0(0 оценок)
Ответ:
Narmahanova
04.10.2021 01:10

from random import randint

mass = [randint(-10, 10) for s in range(20)]

print(mass)

mult = 1

posit = negat = 0

for i in mass:

   if i:

       mult *= i

   if i < 0:

       negat += 1

   if i > 0:

       posit += 1

print(f'Произведение чисел = {mult}\nКоличество положительных чисел = {posit}\nКоличество отрицательных чисел = {negat}')

print(f'Больше {"отрицательных" if posit - negat < 0 else "положительных"} чисел на {abs(posit - negat)}')

Объяснение:

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота