ВЛАД98878
05.01.2020 09:20

Дан массив a длины 3 из целых чисел. Определим операцию изменения массива: выбирается два различных индекса i
и
j
(
1
≤
i
,
j
≤
3
,
i
≠
j
), после чего
a
[
i
]
становится равным
a
[
i
]
−
a[
]

.

Пример операции: дан массив

[

1

,

−

3

,

2

]

, выбрали

i

=

2

,

j

=

1

, получили массив

[

1

,

−

3

−

1

,

2

]

=

[

1

,

−

4

,

2

]

.

Определим для массива

a

медиану

m

как значение, расположенное на позиции

2

при сортировке элементов массива

a

.

К примеру, медианой массива

a

=

[
1
,
−
3
,
2
]
является
m
=
1
, так как в сортированном массиве
[
−
3
,
1
,
2
]
именно
1
стоит на позиции
2
.
Назовём медианным индексом такой индекс
i
, что
a
i
=
m
.Обратите внимание, что медианный индекс необязательно единственный: в массиве a = [3,0,3] медиана m = 3, а медианными индексами являются i1 = 1 (a1 = m) и i2 = 3 (a3 = m).Для каждого индекса i массива a выясните, может ли он стать медианным, если можно сделать не более одной операции изменения массива (можно не делать операций вовсе).Формат ввода. В единственной строке даны 3 целых числа ai (−109≤ai≤109), разделенные пробелами. Формат выводаДля каждого индекса i (1≤i≤3) выведите в отдельной строке ответ: YES, если после не более,чем одной операции изменения массива i может стать медианным индексом; NO — иначе.
Примечания:В первом тесте a = [2,6,5].Если сделать операцию изменения i=2,j=3, то получится массив [2,1,5], медиана будет равна 2, а значит i = 1 будет являться медианным индексом.Если сделать операцию изменения i=2,j=1, то получится массив [2,4,5], медиана будет равна 4, а значит i = 2 будет являться медианным индексом. Если не делать никаких операций изменения, то медианой массива
[2,6,5] будет 5, а значит i = 3 будет являться медианным индексом. Аналогично i=3 будет медианным индексом после операции изменения i=3,j=1.Во втором тесте единственной операцией изменения, делающей индекс i=2 медианным, является операция i=2,j=2, но такая операция не является корректной, так как индексы i должны быть различны.

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
katekurmakaeva
05.10.2022 16:04
Задание №1
var
  a, b, n: integer;

begin
  readln(a, b);
  n := a - b;
  case n of
    1..65536: writeln('a>b');
    0: writeln('a=b');
  else writeln( 'a<b');
  end;
end.

Задание №2

var  a: integer;
begin
    writeln('Введите год рождения'); readln(a);
    write('Вы родились в ');
    case a mod 12 of
        0: writeln('год Обезьяны.');
        1: writeln('год Петуха.');
        2: writeln('год Собаки.');
        3: writeln('год Свиньи.');
        4: writeln('год Крысы.');
        5: writeln('год Быка.');
        6: writeln('год Тигра.');
        7: writeln('год Кролика.');
        8: writeln('год Дракона.');
        9: writeln('год Змеи.');
        10: writeln('год Лошади.');
        11: writeln('год Козы.');
  end;
end.
0,0(0 оценок)
Ответ:
Ленка111545
05.01.2023 18:06
Растровый графический редактор — специализированная программа, предназначенная для создания и обработки растровых изображений, то есть графики, которая в память компьютера записывается как набор точек, а не как совокупность формул геометрических фигур. Подобные программные продукты нашли широкое применение в работе художников-иллюстраторов, при подготовке изображений к печати типографским или на фотобумаге, публикации в интернете.

Векторные графические редакторы позволяют пользователю создавать и редактировать векторные изображения непосредственно на экране компьютера, а также сохранять их в различных векторных форматах, например, CDR, AI, EPS, WMF или SVG.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота