Yyyyyyshdvjfc
01.08.2022 04:29

Напишите программу находящую максимальное из четырех чисел (используйте процедуру для поиска максимального из двух чисел)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
lizka12343
23.06.2020 20:27
Var
    a, b, c, d: integer;

function max(i1, i2: integer): integer;
begin
    if i1 > i2 then max := i1 else max := i2;
end;

begin
    read(a, b, c, d);
    writeln(max(max(max(a, b), c), d));
end.

не помню как процедуры писать, но с функциями даже удобнее
0,0(0 оценок)
Ответ:
Дашенька1365
23.06.2020 20:27
Program ufhg;
uses crt;
var a,b,c,d, m: integer;
begin 
readln(a,b,c,d);
m:=a;
if(b>m) then m:=b;
if(c>m) then m:=c;
if(d>m) then m:=d;
writeln(m);
end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота