Дінислам
15.11.2020 21:11

сириус НОК
Напишите программу, которая вычисляет наименьшее общее кратное двух чисел.

Входные данные

Входная строка содержит два натуральных числа, разделённые пробелом, — a и b. Гарантируется, что ответ не превосходит 2⋅109
Выходные данные

Программа должна вывести одно натуральное число: НОК заданных чисел.

Примеры
Ввод
Вывод
14 21
42

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
Shamаn14
15.07.2021 18:50

#include <iostream>

using namespace std;

int main()

{

int a,b;

cin >> a >> b;

for (int i = 1; i < 2*109 +1; i++)

{

 if (i % a == 0 && i % b == 0) {

  cout << i;

  break;

 }

}

return 0;

}

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота