Ученик2281337228
29.03.2021 10:21

Составить программу на языке С++ для рекурсивной функции: s(i)=3*(s(i-2)+sin(0.73))/s(i-1) с начальными условиями: s(0)=l 05; s(1)=l 4; i=2,3…7

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
BlackJack11RUS
21.05.2020 23:20
Существует три философские концепции информации: 1. Атрибутивная концепция. Информация является свойством всего сущего, всех материальных объектов мира. Информация — атрибут всех материальных объектов. 2. Функциональная концепция. Информация возникла вместе со Вселенной. Информация проявляется в воздействии одних объектов на другие, в изменениях, к котоым такие воздействия приводят. Информация — это атрибут, свойственный только живой природе. 3. Антропоцентрическая концепция. Информация существует лишь в человеческом сознании, в человеческом восприятии. Информационная деятельность присуща только человеку и происходит в социальных системах. Создавая информационную технику, человек создает инструменты для своей информационной деятельности
0,0(0 оценок)
Ответ:
06637381
26.01.2023 13:38
Const n=10; m=3;
var 
a:array[1..n,1..m] of integer;
i,j,s,k:integer; p:real;
begin
Randomize;
writeln('Исходный массив:');
for i:=1 to n do
 begin
 for j:=1 to m do
  begin
   a[i,j]:=random(81)+20;
   write(a[i,j]:4);
  end;
  writeln;
 end;
s:=0;
for i:=1 to n do
 for j:=1 to m do s:=s+a[i,j];
p:=s/n*0.8;
writeln('p = ',p:5:2);
writeln('Зачислены:');
k:=0;
for i:=1 to n do
 begin
 s:=0;
 for j:=1 to m do s:=s+a[i,j];
 if s>=p then begin write(i,' '); k:=k+1; end;
 end;
writeln;
writeln('k = ',k);
end.

Пример:
Исходный массив:
  58  79  60
  96  63  97
  90  97  57
  29  68  25
  38  75  65
  54  69  42
  44  70  47
  39  49  24
  27  64  36
  68  21  64
p = 137.20
Зачислены:
1 2 3 5 6 7 10 
k = 7
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота