Иван55551
07.05.2021 09:19

Написать программу в C# по типу игры где есть варианты ответа и от них будет зависеть конец, используя Console.WriteLine, if, Console.ReadLine например: вы оказались в незнакомом вам месте ваши действия а-бежать, b-кричать)

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
situan4
09.08.2021 20:25
ответ:

using System;

namespace games_znaniga

{

   class Program

   {

       static void Main(string[] args)

       {

           int x = 0;

           while (x == 0)

           {

               Random rnd = new Random();

               Console.WriteLine("\nПривет! Давай сыграем в 'камень-ножницы-бумага'!\nНажми любую клавишу, чтобы начать!");

               Console.ReadKey(); Console.WriteLine("\nСледуй командам ниже! Значения вводи с клавиатуры без ошибок!\n\nЕсли хочешь выбрать ножницы - введи '1' и нажми 'Enter'" +

                   "!\nЕсли хочешь выбрать камень - введи '2' и нажми 'Enter'!\nЕсли хочешь выбрать бумагу - введи '3' и нажми 'Enter'!\n");

               string a = Console.ReadLine();

               if ((a != "1") && (a != "2") && (a != "3"))

               {

                   Console.WriteLine("Ты ошибся при вводе =(\nНажми любую клавишу, чтобы начать игру заново!\n");

                   Console.ReadKey();

                   continue;

               }

               int b = rnd.Next(1, 4);

               int n = Convert.ToInt32(a);

               if (n == b)

               {

                   Console.WriteLine("\nНичья! Компьютер выбрал то же, что и ты =)");

               }

               if ((n == 1) && (b == 2))

               {

                   Console.WriteLine("\nТы проиграл! Компьютер выбрал камень и размозжил в щепки твои ножницы!");

               }

               if ((n == 1) && (b == 3))

               {

                   Console.WriteLine("\nТы выиграл! Компьютер выбрал бумагу! Ты порезал его на части!");

               }

               if ((n == 2) && (b == 1))

               {

                   Console.WriteLine("\nТы выиграл! Компьютер выбрал ножницы! Твой камень размозжил их в щепки!");

               }

               if ((n == 2) && (b == 3))

               {

                   Console.WriteLine("\nТы проиграл! Компьютер выбрал бумагу, в которую обернул твой камень!");

               }

               if ((n == 3) && (b == 1))

               {

                   Console.WriteLine("\nТы проиграл! Компьютер выбрал ножницы, он разрезал твою бумагу!");

               }

               if ((n == 3) && (b == 2))

               {

                   Console.WriteLine("\nТы выиграл! Компьютер выбрал камень, ты завернул его в бумагу!");

               }

               Console.WriteLine("\nНажми '1', если хочешь начать игру заново!\nИначе нажми любую клавишу, чтобы закончить игру!\n");

               string d = Console.ReadLine();

               if (d != "1")

               {

                   Console.WriteLine("Игра завершена!\nЗакрой это окно нажатием любой клавиши!");

                   x += 1;

               }

           }

           

       }

   }

}

Пояснение:

Игра "камень-ножницы-бумага" на С#.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота