Руслана5999226
18.08.2022 00:01

PYTHON На плоскости дан набор точек с целочисленными координатами. Необходимо найти треугольник наибольшей площади с вершинами в этих точках, одна из сторон которого лежит на оси OX. Напишите эффективную, в том числе по памяти, программу, которая будет решать эту задачу. Размер памяти, которую использует Ваша программа, не должен зависеть от длины переданной последовательности чисел.
В первой строке вводится одно целое положительное число – количество точек N (N <= 1000).
Каждая из следующих N строк содержит два целых числа – сначала координата х, затем координата у очередной точки. Все координаты по модулю не боле 1000.
Программа должна вывести одно число – максимальную площадь треугольника, удовлетворяющего условиям задачи. Если такого треугольника не существует, программа должна вывести ноль.

Входные данные
В первой строчке вводится одно натуральное число - количество точек N . Каждая из следующих N строчек содержит по два целых числа - координата по x и по y.

Выходные данные
Программа должна вывести одно число - максимальную площадь треугольника, удовлетворяющего условию задачи. Если такого треугольника не существует, то программа должна вывести 0.
PYTHON

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
chcuvivhcyxu
09.02.2020 08:29
Червь  – программа, которая делает копии самой себя. Ее вред заключается в захламлении компьютера, из-за чего он начинает работать медленнее. Отличительной особенностью червя является то, что он не может стать частью другой безвредной программы.Троянская программа (троянский конь, троян)Троянская программа маскируется в других безвредных программах. До того момента как пользователь не запустит эту самую безвредную программу,  троян не несет никакой опасности. Тронская программа может нанести различный ущерб для компьютера. В основном трояны используются для кражи, изменения или удаления данных. Отличительной особенностью трояна является то, что  он не может самостоятельно размножаться.
0,0(0 оценок)
Ответ:
gg228
18.11.2021 12:00
Program q1;
uses crt;
const n=10;
var i,j:integer;
mass:array [1..n] of integer;
countNum:integer; // переменная для хранения количества нечетных чисел
proizv:integer; // переменная для хранения произведения нечетных чисел
BEGIN
proizv:=1; // так как, изначально равно 0, а при умножении на 0 будет всегда 0
{создание последовательности n целых чисел}
Writeln('Случайные целые числа: ');
for i:=1 to n do
begin
mass[ i ]:=random(9)+1; //присваеваем переменной случайное значение от 1 до 10
write(inttostr(mass[ i ])+', ');
end;
{Вычисление произведения и количества нечетных чисел}
for i:=1 to n do
if mass[ i ] mod 2 <> 0 then //проверяем не четное-ли число, если да, то.. .
begin
inc(countNum); //увеличиваем на один кол-во нечетных чисел
proizv:=proizv*mass[ i ]; // высчитываем произведение
end;
{Вывод результатов}
writeln;
writeln('Всего нечетных чисел: '+inttostr(countNum));
writeln('Их произведение: '+inttostr(proizv));
END.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота