Тамерлашкой
06.04.2022 09:42

Написать программу на c++, которая переводит число из двоичной системы счисления в десятичную

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
abakanilaha
01.10.2020 12:27

#include <iostream>

#include <string>

#include <cmath>

using namespace std;

void main(void){

setlocale(LC_ALL, "rus");

int i,sum=0,n,r=0;

char date[255];

cout << "Введите двоичное число"<< endl;

cin >> date;

n = strlen(date);

int *arr = new int[n];


for (i = 0; i < n; i++){

 arr[i] = (int)date[i] - (int)'0';

}

for (i = 0; i < n; i++){

 cout << arr[i] << " ";

}

cout << " " << endl;

for (i = 0; i < n; i++){

 r = r + arr[i]*pow(2, n - i-1);

}

cout << "Десятичное число равно" << r;


}


Написать программу на c++, которая переводит число из двоичной системы счисления в десятичную
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота