AMG777555
06.11.2021 03:10

написать программу на C++! Нужно создать кольцевой список через классы. Обязательны функции-члены класса для
добавления/удаления элемента, проверки присутствия указанного элемента,
вывода текущих элементов списка.

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
hohlov228
07.03.2021 09:39

Текст программы приложил в фото, если есть какие-то вопросы или уточнения, обращайтесь, с радостью отвечу.

#include <iostream>

using namespace std;

int main() {

   double A;

   int S{0}, counter{1};

   cout << "Enter number: ";

   cin >> A;

   //Цикл с постусловием

   do

   {

       S += counter;

       counter++;

   } while (A > S);

   cout << S << '\n';

   counter = 1;

   S = 0;

   //Цикл с предусловием

   

   while (A > S)

   {

       S += counter;

       counter++;

   }

   cout << S << '\n';

}

0,0(0 оценок)
Ответ:
alicemuhametp0aof9
22.07.2020 03:55

Объяснение:

1. var i: integer;

var z, s: double;

begin

i := 1;

z := 512;

s := 0;

while i <= 10 do

 begin

  s := s + i/z;

  inc(i);

  z := z/2;

 end;

writeln(s:0:2);

end.

2. var i, k: integer;

begin

i := 0;

k := 0;

repeat  

 inc(i);

 if ((i mod 2) = 0) then inc(k);

until i=5;

write(k);

end.

3. var i, n: integer;

begin

i := 0;

n := 0;

while i<10 do

 begin

  n := random (31) + 10;

  if ((n mod 2) = 0) then  

    begin

      writeln(n);

      inc(i);

     end;

 end;

end.

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота