Последовательность чисел назовем симметричной, если она одинаково читается как слева направо, так и справа налево. Например, следующие последовательности являются симметричными:
1 2 3 4 5 4 3 2 1;
1 2 1 2 2 1 2 1.
Вашей программе будет дана последовательность чисел. Требуется определить, какое минимальное количество и каких чисел надо приписать в конец этой последовательности, чтобы она стала симметричной.
Формат входных данных
Сначала вводится число N — количество элементов исходной последовательности (1≤N≤100). Далее идут N чисел — элементы этой последовательности, натуральные числа от 1 до 9.
Формат выходных данных
Выведите сначала число M — минимальное количество элементов, которое надо дописать к последовательности, а потом M чисел (каждое — от 1 до 9) — числа, которые надо дописать к последовательности.
1) const n=5; var a:array[1..n,1..n]of integer; i,j:integer; begin for i:=1 to n do begin writeln; for j:=1 to n do begin a[i,j]:=i+j; write(a[i,j]:4); end; end; end. 2) const n=4;m=5; var a:array[1..n,1..m]of integer; i,j,max:integer; begin for i:=1 to n do begin writeln; for j:=1 to m do begin a[i,j]:=random(100)-50; write(a[i,j]:4); end; end; max:=a[1,1]; for i:=1 to n do for j:=1 to m do if a[i,j]>max then max:=a[i,j]; writeln; writeln(max); for i:=1 to n do for j:=1 to m do if (a[i,j]<0)and(a[i,j]>-5)then a[i,j]:=max; writeln; for i:=1 to n do begin writeln; for j:=1 to m do write(a[i,j]:4); end; end.
Const n=20; type v=array[1..n] of integer; w=array[1..n div 2] of integer; var a:v;
procedure FormW(var pa:w;pOdd:boolean); { При pOdd=true формируется массив из нечетных элементов, при false - из четных } var i,k:integer; begin k:=0; if pOdd then i:=1 else i:=2; while i<=n do begin Inc(k); pa[k]:=a[i]; i:=i+2 end end;
var b,c:w; i:integer;
begin Randomize; Writeln('Элементы исходного массива'); for i:=1 to n do begin a[i]:=Random(50); Write(a[i]:3) end; Writeln; FormW(b,false); Writeln('Массив из элементов с четными номерми'); for i:=1 to (n div 2) do Write(b[i]:3); Writeln; FormW(c,true); Writeln('Массив из элементов с нечетными номерми'); for i:=1 to (n div 2) do Write(c[i]:3); Writeln end. Тестовое решение: Элементы исходного массива 11 37 22 43 44 14 3 29 2 25 0 30 37 44 24 45 34 30 39 42 Массив из элементов с четными номерми 37 43 14 29 25 30 44 45 30 42 Массив из элементов с нечетными номерми 11 22 44 3 2 0 37 24 34 39
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку