, нужно решить уравнение в паскале x≤3→y=x2 x>3→y=x−7*x 2. Написать программу, выводящую числа, которые делятся на 3 без остатка, в промежутке от 10 до 30.
В каталоге уровень "вверх" означает движение к корневому каталогу, "вниз - от корневого. Обозначим движение "вверх" через уровень+1, "вниз" - через уровень-1. Получаем смещение относительно исходного уровня, равное +1-1-1-1=-2. Если в результате пользователь оказался в каталоге C:\учеба\информатика \ ГИА, то изначально он должен был находиться на два уровня выше, т.е. в каталоге C:\учеба К сожалению, такого варианта в ответах нет, следовательно, либо неверно условие, либо ошибка в вариантах ответов.
Var s,sd,sm,sy:string; d,m,y,err:integer; begin Write('Введите текущую дату в формате дд/мм/ или дд.мм.: '); Readln(s); if Length(s)<>10 then Writeln('Неверный ввод') else begin sd:=s[1]+s[2]; Val(sd,d,err); sm:=s[4]+s[5]; Val(sm,m,err); sy:=Copy(s,7,4); Val(sy,y,err); if err>0 then Writeln('Неверный ввод') else begin if d<28 then d:=d+1 else begin case m of 1,3,5,7,8,10,12: if d<31 then d:=d+1 else begin d:=1; m:=m+1 end; 2: if (y mod 4)=0 then if d=28 then d:=29 else begin d:=1; m:=3 end else begin d:=1; m:=3 end; else if d<30 then d:=d+1 else begin d:=1; m:=m+1 end end end; if m>12 then begin m:=1; y:=y+1 end; Str(d,sd); if Length(sd)=1 then sd:='0'+sd; Str(m,sm); if Length(sm)=1 then sm:='0'+sm; Str(y,sy); s:=sd+'.'+sm+'.'+sy; Writeln('Завтра будет '+s) end end end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку