Lena2402bux
12.01.2020 01:58

Сделать программу с двумерного массива , только при создание используйте printf(),scanf() вместо заранее


Сделать программу с двумерного массива , только при создание используйте printf(),scanf() вместо зар

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
HelpDZ1
10.03.2023 10:13
1. Консольное приложение:

Module Module1

    Sub Main()
        Dim n, i, s As Integer
        Console.Write("Введите число N")
        n = Console.ReadLine
        s = 0
        For i = 1 To n
            s = s + i * i
        Next
        Console.Write(s)
        n = Val(Console.ReadLine)

    End Sub

End Module

2. Приложение Windows Forms:
На форме 3 объекта:
TextBox1 - для ввода N
Textbox2 - для вывода суммы квадратов
Button1 - чтобы запустить процесс вычислений

Public Class Form1

    Private Sub Button1_Click(ByVal sender As System.Object, ByVal e As System.EventArgs) Handles Button1.Click
        Dim i, s As Integer
        s = 0
        For i = 1 To Val(TextBox1.Text)
            s = s + i * i
        Next
        TextBox2.Text = s
    End Sub
End Class
0,0(0 оценок)
Ответ:
alisherpitbul
09.05.2023 22:42

В обоих заданиях нет самомого главного - не описан интерфейс с пользователем, функции пользователя и функции программы. Без этого программа не пишется. Ведь ты, по сути, формулируешь техническое задание на программирование, а в нём не должно быть неясностей для программиста, он  должен взять листочек и тупо закодировать то, что там написано.

Ну, например, по заданию 1 могут быть варианты:

1. Написать программу, которая , при этом в каждом поединке победа присуждается с вероятностью 1/3, поражение с вероятностью 1/2, ничья с вероятностью 1/6. По окончании расчетов вывести турнирную таблицу в порядке занятого места.

 

В этом случае пользователь ничего не делает и интерфейса, как такового, нет, он просто нажимает "пуск", а программа всё сама делает и выводит результаты на печать.

 

2. Написать программу, которая, при этом участники каждого турнира выводятся на экран, а пользователь сам определяет его результат(победа, ничья, поражение). По окончании турниров программа віводит турнирную таблицу в порядке занятого места.

 

В этом случае пользователь всё время в диалоге, потому что именно он должен определять результат каждого турнира.

 

Вот 2 разных сценария интерфейса к одному и тому же, что написано в задании, но программы, их сложность достаточно различаются.

 

Резюме. Если хочешь, чтобы тебе качественно а не отписались, сформулируй задания снова, лучше каждое отдельным заданием и так, чтобы тебе самой было понятно, что ты хочешь от программы.

Успехов!

 

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота