Составить программу на Delphi для нахождения максимального и минимального элемента двухмерного целочисленного массива из 24 элементов (Это всё что было в задании)
В культуре Месопотамии особое место принадлежит клинописи. Наличие письменности — характерная особенность ранних цивилизаций Передней Азии. Развитая клинописная система передавать все оттенки шумерской речи, возникла уже к середине III тысячелетия до нашей эры. «Письменность — одно из самых существенных культурных завоеваний человека. Хотя, казалось бы, она играет в истории культуры подсобную, техническую роль, очевидно, что без нее не было бы возможно то огромное культурное развитие человечества от каменного века до атомного века, которое сделало современный мир таким, каким он является ныне», — писал И. М. Дьяконов.
Клинопись развилась из пиктографии — примитивного рисуночного письма, содержавшего свыше полутора тысяч знаков-рисунков. Каждый клинописный знак — их насчитывалось около четырех сотен — мог в зависимости от контекста читаться и как слог, и как1 целое слово. Для людей, знавших язык, выбор того или иного чтения знака не составлял особого труда, т. к. лишь 70 — 80 знаков были наиболее употребительными. Кстати, в них почти невозможно было узнать исходный знак-рисунок.
Самые древние письменные сообщения представляли собой своего рода ребусы, понятные только их авторам. По-видимому, это были описи полученных или выданных продуктов и имущества. К числу древнейших относя и учебные тексты — списки знаков, слов и т. д.
Превратившись в слоговое письмо, клинопись позволила не только передавать слова шумерского языка, по и писать на языках совершенно другого типа. Уже в III тысячелетии до нашей эры аккадцы, а затем и другие семитские племена, заимствовали у шумеров их шрифт и при его к своему языку. Эта письменность распространилась и дальше — ее переняли эламиты на востоке, сирийцы и финикийцы на западе, а также хетты — индоевропейский народ, населявший Анатолию, так что клинопись завоевала всю Переднюю Азию. Впоследствии клинообразное письмо применялось также в Урарту и Персидском царстве.
Значит так...очередная нудная программа с простым алгоритмом.
Печатает начальный массив, потом диагональ(в уже измененном массиве), потом новый массив, потом число элементов 19..59, произведение диагонали, сумму элементов столбца s.
program test; uses crt; var arr:array[1..8,1..8] of integer; i,j,cou,pr,s,sum:integer; begin clrscr; randomize; pr:=1; s:=7; for i:=1 to 8 do begin for j:=1 to 8 do begin arr[i,j]:=random(127)+2; write(arr[i,j],' '); end; writeln; end;
writeln; for i:=1 to 8 do for j:=1 to 8 do begin if (arr[i,j]>18) and (arr[i,j]<60) then begin cou:=cou+1; arr[i,j]:=0; end;
if i=j then begin pr:=pr+arr[i,j]; write(arr[i,j],' '); end;
if j=s then sum:=sum+arr[i,j]; end; writeln;writeln; for i:=1 to 8 do begin for j:=1 to 8 do write(arr[i,j],' '); writeln; end; writeln; writeln(cou); writeln(pr); writeln(sum); readln; end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota
Оформи подписку