egor51t76rc
13.11.2021 17:04

с ! Напишите программу для сортировки файлов определенного типа по дате в текущем каталоге. Тип файла вводится в формате как во входных данных.

Например ввод:
*.py

Вывод:
exercises.py
namespace.py
some_module.py
1234.py
locales_print.py
bottle.py

Нажмите на рекламу ниже и сразу увидите ответ
Популярные вопросы:
Ответ:
karinasarova95
31.12.2020 04:07
 Одним из фундаментальных понятий в информатике является понятие алгоритма.      Алгоритм (в матемтике) - это формально описанная вычислительная процедура, получающая исходные данные, называемые так же входом алгоритма или его аргуметом, выдающая результат вычислений на выход, и обладающая свойствами: массовость, определенность, конечность и детерминированность.     Алгоритм (в информатике) - это точное и понятное предписание (указание) исполнителю совершить определенную последовательность действий, направленных на достижение указанной цели или решение поставленной задачи.
0,0(0 оценок)
Ответ:
lastok
01.11.2022 11:17
var
m,n,i,j:integer;
bool:boolean;

begin
readln(n,m); //читаем Н и М
for i:=n to m do begin  // От Н до М выполняем цикл
bool:=false;  // Обнуляем переменную для каждой итерации
 
for j:=2 to i-1 do
begin  // Проверяем, делится ли число на числа, которые находятся в промежутку от 2 до это число -1   

if (i mod j=0) then bool:=true; //если делится, тогда bool:=true  
end;

if (bool = false) then write(i,' ');  //если bool = false, значит это число делится только на себя и на 1, а значит оно простое и выводим это число

end;

end.
0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота