суперкот78
24.11.2022 13:52

Сумма факториалов. КОД НУЖНО НАПИСАТЬ НА PYTHON.

По данному натуральном n вычислите сумму 1!+2!+3!+...+n!. В решении этой задачи можно использовать только один цикл.

Входные данные:

Вводится натуральное число n, не превосходящее 30.

Выходные данные:

Выведите ответ на задачу.

Примеры:

Ввод: 3
Вывод: 9

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
noer2000
10.07.2021 13:11

Відповідь:

Пояснення:

import math

n = int(input('число менше 30'))

s = 0

for i in range (1, n+1):

   m = math.factorial(i)

   s = s + m

print('1!+2!+3!+...+',n,'! = ',s)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота