311020029332
13.10.2022 08:39

Составить программу для выполнения действий с массивами


Составить программу для выполнения действий с массивами

Нажмите на рекламу ниже и сразу увидите ответ
↓
Популярные вопросы:
Ответ:
Сиронарк
11.06.2022 06:58

                  34,8г 5%                                         хг   

Ba(NO3)2  +  K2SO4         =    2KNO3    +   BaSO4

                   v=1моль                                   v=1моль

                   М=174г/моль                            М=233г/моль

                   m=174г                                     m=233г

найдем массу соли

m(K2SO4)=(34,8г*5%)/100%=1,74г

сост.пропорцию

1,74гхг

174г233г

х=(233г*1,74г)/174г=2,33г

вместо пропорции можно решить через моль:

v(K2SO4)=1,74г/174(г/моль)=0,01моль

v(BaSO4)=v(K2SO4)=0,01моль

m(BaSO4)=0,01моль*233(г/моль)=2,33г

ответ: 2,33г

0,0(0 оценок)
Ответ:
goddessshi
29.01.2022 12:23

ответ: Только не точь в точь, а то за это бан)

#include <iostream>

#include <vector>

#include <cstdint>

using namespace std;  template <class T>

istream& operator>>(istream &in, vector<T> &vec) {   for (auto &it : vec)     in >> it;   return in;

}

template <class T>

ostream& operator<<(ostream &out, vector<T> &vec) {   for (auto &it : vec)     out << it << ' ';   return out;

}  

template <class T, class U>

istream& operator>>(istream &in, pair<T, U> &pair){

  in >> pair.first >> pair.second;   return in;

}  

template <class T, class U>

ostream& operator<<(ostream &out, pair<T, U> &pair) {   out << pair.first << ' ' << pair.second;   return out;

}

signed main(void) {     int32_t n; cin >> n;     vector<vector<int64_t>> a(n, vector<int64_t>(n,-1));      

int64_t x = 0, y = n/2;      

a[x][y] = 1;      

for(int32_t i = 2; i <= n*n; ++i) {        

int _x = x, _y = y;          

if(!x) {              

x =  n-1;          

}else {              

x-=1;        

}          

if(y == n-1){            

y = 0;          

}else {            

y++;          

}          

if(a[x][y] != -1){            

 x= _x, y = _y;              

 while(a[x][y] != -1){                  

 if(x == n-1){                    

  x = 0;                  

  }else{                      

  x++;                  

  }            

 }          

}          

a[x][y] = i;      

}      

for(int32_t i = 0; i < n; ++i){          

cout << a[i] << '\n';      

}      

return 0;  

}

У вас есть 4-ая? Я щас создам вопрос!

Если , оцени)

0,0(0 оценок)
Полный доступ
Позволит учиться лучше и быстрее. Неограниченный доступ к базе и ответам от экспертов и ai-bota Оформи подписку
logo
Начни делиться знаниями
Вход Регистрация
Что ты хочешь узнать?
Спроси ai-бота